myLittleTools Community Forum

Welcome Guest Search | Active Topics | Members | Log In | Register

Lite and SQLExpress - can't local connect Options · View
Posted: Sunday, April 19, 2009 4:27:32 PM
Rank: Newbie
Groups: Member

Joined: 4/19/2009
Posts: 2
Points: 6
I'm not new to SQL but completely new to SQL Server, so thought I installed myLittleAdmin Lite to manage it, as I like that it seems much more intuitive for viewing data and tables than Microsoft's SQL Server Man. Studio tool for SQL management (which doesn't appear to display data at all). So, I've installed SQL Express 2008 and myLittleAdmin Lite: but get this message on trying to connect

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections."

I know the db is fine, as no problem connecting with SQL Server Man. Studio. As per install guide I have done following:
- config file set '<sqlserver address="" name="localhost" />'
- littleAdmin is recognized as an application by IIS
- I also turned on debugging feature in config file

Further, in the course of troubleshooting, I have used the SQL Config Manager to enabled TCP/IP Protocols for remote connections, and activated the Browser Service. I also temporarily turned off my Firewall to eliminate that possiblity, but go the same result.

Is my problem authentication? I am using Windows Authentication without anything in the Login or Password field simply because that is how it is working in the SQL Server Man. Studio

Or it is the Network Protocols: The message about not connecting is always the same but is followed by a brief explanation depending on which protocol I choose. At first, I used the default and the explanation read "(provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)". Then, after enabling TCP/IP this is what I got: "(provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.)"
From this, it looks as thought the TCP/IP protocol is at least communicating.

Sorry for this windy message, I just include all the info for clarity.
Any help greatly appreciated.
Posted: Tuesday, April 21, 2009 1:35:57 PM
Rank: Newbie
Groups: Member

Joined: 4/19/2009
Posts: 2
Points: 6
Solved my problem. Found out how to create a user login in SQL Management Studio and now using Server Authentication instead of Windows Authentication.
Posted: Thursday, April 23, 2009 7:32:44 AM

Rank: Administration
Groups: Administration

Joined: 9/11/2006
Posts: 605
Points: 649
Location: Enghien Les Bains, France
Sorry to come so late but glad you solve this prob.
Users browsing this topic

You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Main Forum RSS : RSS

Theme created by myLittleTools
Powered by Yet Another version (NET v2.0) - 3/29/2008
Copyright © 2003-2008 Yet Another All rights reserved.